Issue with Data Import Tool

12 posts 0 new
Log in or register to post comments.

Pages

Issue with Data Import Tool

Hi.

I've tried to import data with QPR Data Import tool and got the following error ActiveX component can't create object, error: 429

I use QPR 2016.1, Windows 10 x64 PRO launched from Mac as a virtual machine (with help Parallels Tools).

I’ve installed VB tools and switched on IIS in the Window's features. That didn't help.

 

Does anybody met the same issue? Maybe you have any recommendations?

Hi Valentine, allthough happy that this tool exists I found this data import script still to unstable and to technical for our customers to use. I wrote a userfriendly application myself that is available via SPNP consulting. The 'Excellerator' tool is a simple import and export wizard application (.exe) that autodetects the modeldesign of the model you selected using a click and point interface. It exports data from QPR EA/PD into excel in a few clicks, and imports any of your attributes, attribute sets, or relations back into QPR (validating any differences fist before you import). You are ready in seconds and you can limit the access to any user.

If you are interested you can download a demo version here. It is fully functional for QPR2016.1 and QPR2017.1 as long as you use the default demo/qpr account (also make sure that when you start it up the first time you fill in the config tab first and save the settings).

Hope this helps you,

kind regards, 

Remko

Hi,

I've tried to run the app, it said that QPR 2016.1 is not supported and I need to obtain the correct version of the app. I use QPR 2016, may be you have an older version of the app?

Hey Valentine,

 

I checked the Data Import tool page and looks like 2016.1 version is not compatible with this accelerator:
"Compatible with: QPR Suite 2015.1, QPR Suite 2014.1"

Hi Tomi,

That sounds strange, because my colleague is using Data Import Tool with QPR 2016. She had error in syntax and she asked me to look at a configuration file. I fixed the file and now she uses the tool again. After her request, I decided to install the tool on my PC and got the error.

Hey Valentine,
Sorry for the delay,
Please try the following:
1,Go to the installation folder for the affected client component
2. Launch the executable with the /regserver command line switch, i.e. QPR.Modeling.Client.exe /regserver for QPR Modeling Clients or QPR.Metrics.Client.exe /regserver for QPR Metrics.

After that try again

Hi,

It didn't help, I got the following error. Error creating system registry entry.

 

Details can be find by the link https://www.dropbox.com/s/e0fsq60tri2z29f/RegError.txt?dl=0

Hey Valentine,

I can see that you have version mismatch in that error.txt

Modeling client is version 
2016.1.0.35534

Modeling resource:
2016.1.0.35089
 

I checked my 2016.1 client and it is version 2016.1.0.35089

 

Could you try to download the 2016.1 clients again from community and then reinstall and try again

 

Hi Tomi,

With a new version, error doesn't appear. But now I faced with another strange behavior. After I select configuration file, the tool said that the excel file cannot be found. I've checked the directory many times. I have pasted it in the windows explorer and file has opened. May be you've heard about any issues with the tool when it works under virtual machine?

Hi Valentine, (I'd like to respond to your comment on 21/8/17). Here (download link) is an older version to the all-in-one Excelerator.exe compatible with 2016.1 from SPNP Connsulting.

 

 

Hi Remko.

I tried both versions and both show an authentication error. I tried my personal credentials and QPR demo user and I got the same result. When I tried local model, the application showed critical error and closed.

Pages